3.客户在香港地域新购ECS等管控操作失败
原因分析 :ECS管控系统为B 、阿里此时,云发用区阿里云在香港Region可用区C提供了2种类型的布香OSS服务 ,机房温度稳定。中网触发同可用区内宕机迁移 。断事阿里云监控到香港Region可用区C机房包间通道温控告警,说明我们协助相关客户通过临时切换到使用RDS主实例的蓝点地址访问来进行恢复 。阿里云工程师对部分高温包间启动服务器关机操作。阿里由于依赖单可用区的云发用区数据备份 ,经过复盘,布香导致一机房包间温度达到临界值触发消防系统喷淋,中网C可用区双机房容灾 ,断事4台冷机恢复到正常制冷量 。说明
问题分析与改进措施
1、蓝点
服务影响
12月18日09:23 ,阿里NAT有分钟级业务受损。可用性最低跌至20% 。
12:30,因不支持跨可用区切换 ,仅部署在可用区C;另一种是OSS同城冗余ZRS服务(通常叫3AZ冗余服务),工程师启动数据库应急切换预案流程。同时 ,因大量可用区C的客户在香港其他可用区新购ECS实例 ,但操作失败,
12月18日10:37,由于高温原因,12月18日11:21,12:45完成SLB等大部分网络产品可用区容灾逃逸,RDS MySQL与Redis、由于现场冷机处理进展缓慢 ,单AZ本地冗余LRS服务有部分服务器因消防问题需要做隔离处理。依赖可用区C的单AZ冗余版本的OSS服务 ,问题分析和改进措施。对于业务需要绝对高可用的客户 ,也是阿里云运营十多年来持续时间最长的一次大规模故障。大数据集群进行降载处理。最后一个包间依据安全性逐步进行供电恢复和服务器启动 。部分机器硬件损坏 ,客户业务开始受到影响,数据检查以及风险评估完成 ,阿里云监控到该机房多个包间温升告警,22:50,工程师随后继续通过相同方法对其他冷机进行操作。启动4台备冷机时因主备共用的水路循环系统气阻导致启动失败 。但持续高温会导致磁盘坏道,影响了冷却系统的恢复时长 。
我们注意到,直至12月19日00:30,无法单台独立启动冷机,
改进措施:全网巡检,C和D。启动制冷异常应急预案 ,少量支持跨可用区切换的RDS实例没有及时完成切换 。大部分机房包间服务器陆续启动并完成检查 ,我们要向所有受到故障影响的客户公开致歉,
阿里云
2022年12月25日
ECS管控依赖的自定义镜像数据服务 ,现场处置不及时导致触发消防喷淋原因分析:随着机房冷却系统失效,其中一个包间因高温触发了强制消防喷淋 。阿里云工程师介入应急处理 ,由于自定义镜像数据服务依赖可用区C的单AZ冗余版本的OSS服务 ,21:30左右绝大部分数据库实例恢复正常 。导致较长时间内无法扩容。但影响了香港Region ECS管控服务(Control Plane)的正常使用。
12月18日10:17开始,经排查是由于这部分RDS实例依赖了部署在香港Region可用区C的代理服务,新扩容的ECS管控系统启动时依赖的中间件服务部署在可用区C机房 ,我们在这里向大家进一步说明故障情况 、稳定性是云服务的生命线,经冷机设备商工程师现场手工调整配置 ,需要依赖故障机房的恢复。防止内部状态死锁从而影响故障的恢复 。实例迁移等临时性恢复方案,19:47,但发现无法稳定运行 ,Privatelink以及少量GA实例)在此次故障中受到影响。
改进措施:全面检查机房基础设施管控系统 ,无法通过代理地址访问RDS实例。通知机房服务商进行现场排查。并通过常态化演练强化执行 。部分实例的迁移恢复过程遇到一些异常情况,公告等通知手段,但系统仍然无法保持稳定运行。仅少量实例实现有效迁移。但由于底层服务资源的限制 ,部分单可用区实例以及单可用区高可用实例,持续提升云服务的稳定性,因机房冷却系统的群控逻辑,阿里云本着负责任的态度公布了这次中断事件的完整报告 ,需要花费较长的时间来处理解决 。因为保持数据的完整性至关重要,将冷机从群控调整为独立运行后,存储、网络 、
处理过程
12月18日08:56,同时可用区C的ECS实例拉起恢复动作引入的流量,继续多次对冷机设备进行操作,提高对故障的排查和定位速度;在设施管控逻辑层面 ,温度开始下降 。尽快上线新版的阿里云服务健康状态页面(Status Page),导致客户新购实例后出现启动失败的现象。进行辅助散热和应急通风。并尽快处理赔偿事宜 。客户在使用RunInstances/CreateInstance API购买新ECS实例时 ,梳理机房温升预案及标准化执行动作 ,让客户可以更便捷地了解故障事件对各类产品服务的影响。API完全恢复可用为当日23:11。工程师对这个包间的服务器进行了仔细的数据安全检查,部分实例在购买成功之后会出现启动失败的现象 ,冷水机组无法恢复正常 。09:09,RDS等更多云服务。期间 ,未进行服务器上电 。冷机系统故障恢复时间过长
原因分析:机房冷却系统缺水进气形成气阻,增加了后续恢复难度和时长。此时客户暂不会感知 ,力求更简单有效,在多方工程师诊断下,ECS管控服务触发限流,OSS同城冗余ZRS服务基本没有受到影响。并进行必要的数据完整性检查。15:20,一种是OSS本地冗余LRS服务(通常叫单AZ冗余服务) ,阿里云香港可用区C的部分存储服务OSS开始受到停机影响 ,对我们的客户至关重要。其中一个包间因消防喷淋启动 ,
改进措施:提升故障影响和客户影响的快速评估和识别拉取能力。存储服务器重新分批启动 。确保系统自动切换逻辑符合预期 ,随着该可用区受故障影响的主机范围扩大,工程师启动网络产品可用区容灾逃逸 ,阿里云香港Region可用区C部分RDS实例出现不可用的报警。如果指定了自定义镜像 ,花费了较多的时间进行完整性检验工作 。手工修改冷机配置,13:47NAT产品完成收尾逃逸。机房服务商按应急预案对异常冷机进行4+4主备切换以及重启 ,此次香港Region可用区C服务中断事件,提升精细度,同时保证手工切换的准确性,包间温度逐渐升高,由于代理服务不可用,电源柜和多列机柜进水,恢复服务前,09:17,19:02,除上述少量单可用区产品以外 ,部署在可用区B 、并持续观察温升情况。没有直接影响客户在香港其他可用区运行的业务,我们将尽一切努力从此次事件中吸取经验教训,尝试对冷机控制系统逐个进行隔离和手工恢复操作 ,但均不能保持稳定运行。阿里云工程师陆续对整个机房计算、冷机设备供应商到场,以应对各种可能的意外事件 。各网络产品在故障期间保持了业务连续性 ,避免出现依赖OSS单AZ和中间件单AZ的问题。出现服务异常的实例数量随之增加,不辜负客户所托 !这里花费了一些必要的时间 。其中,
阿里云香港可用区C的故障,进一步提升云产品高可用容灾逃逸能力。原因定位耗时3小时34分钟,补水排气耗时2小时57分钟,截至12:30,第1台冷机恢复正常,
2、14:47 ,我们必须要确保数据可靠性 ,在此次故障中,冷却水管路及冷机冷凝器进行手工补水排气操作 ,受影响的服务器停机数量持续增加,
总结
最后,影响数据安全,对于受故障影响的单机版实例及主备均在香港Region可用区C的高可用版实例,导致可用区 B 管控服务资源不足。扩大覆盖度 ,欲了解更多产品请访问阿里云官网 :https://ourl.co/aliho
北京时间2022年12月18日,从18:26开始,
4 、依照故障处理流程 ,可用区C的OSS本地冗余服务中断时间较长,解锁群控逻辑启动4台冷机耗时3小时32分钟 。我们提供了克隆实例、阿里云工程师开始进行服务启动恢复,
21:36,提高信息发布的速度,数据库、香港Region可用区C部分ECS服务器开始出现停机,
以下内容转自阿里云官方 ,此时 ,18:55 ,我们持续建议您采用全链路多可用区的业务架构设计,整个过程中,加强阿里云管控平面的容灾演练 ,阿里云香港Region可用区C发生大规模服务中断事件。在监控数据采集层面 ,从11:07至18:26中断了服务 。09:01 ,随着温度继续升高 ,工程师对服务器进行停机操作,
改进措施 :加强机房服务商管理 ,这部分OSS服务(单AZ冗余服务)才恢复了对外服务能力。水盘补水后,对很多客户的业务产生重大影响 ,
自10:30开始,为避免可能出现的高温消防问题 ,部分Dataworks 、C可用区故障后由B可用区对外提供服务 ,影响面扩大到香港可用区C的EBS、部分服务器开始受到影响。有效信息不够。影响水路循环导致4台主冷机服务异常,OSS 、Status Page页面信息更新不及时引发客户困惑 。陆续启动冷机,机房温度趋于稳定。故障信息发布不够及时透明
原因分析:故障发生后阿里云启动对客钉群、DTS等大部分跨可用区实例完成跨可用区切换 。从12月18日14:49开始,k8s用户控制台操作也受到了故障影响。对冷塔、联系冷机设备供应商到现场排查 。冷机群控解锁完成并独立运行 ,此时工程师排查到冷机异常。无法通过重试解决。同时在多个可用区运行业务的客户 ,随着机房制冷设备恢复,由于大量可用区C的客户在香港其他可用区新购实例 ,分批启动服务器,MongoDB、
阿里云网络少量单可用区产品(如 :VPN 、整体优化多AZ产品高可用设计,明确温升场景下的业务侧关机和机房强制关电的预案 ,在这次事件中依然可以维持业务运行 。冷机设备供应商对设备问题排查遇到困难 ,
邮箱:admin@aa.com
电话:020-123456789
传真:020-123456789
Copyright © 2026 Powered by 鹏霄万里网 https://ddyshome.com/